L a b: Multi Cisco Router Configuration

 

 

In 1980 Stanford University asked Bill Yeager to figure out a way to let various mainframes in their Medical Center, Computer Science Department, and Electrical Engineering Department communicate.  Six months later the multiprotocol router was born.  In 1984 Cisco was founded by Stanford engineers Leonard Bosack and Sandra Lerner, and by 1986 they shipped their first TCP/IP router. Now Cisco is the standard in switching and routing technology.

 

In this Lab you will configure routers to allow two computers on different subnets to communicate. We will use the GNS3 Graphical Network Simulator, and VPCS Virtual PC Simulator.

 

Objectives:

          Configure the VPCS Virtual machines.

Create the network Topology in GNS3.

Configure the router, the router’s port, and the dynamic routing protocol.

Send traceroute packets from one machine to another to show connectivity.

          Observe the packets you created to test the network and the packets the router uses to determine its own topology.

 

Lab Setup Diagram:                       

 

 

 

Step 1          Logon On to VM Ware as directed from the following website:

https://www.up.ist.psu.edu/vhol/gettingstarted-web.php

 

Step 2         
You may need to logon to the linux virtual machine with the user name “ Administrator ” (no quotes). The password is “ password ” (no quotes).

 


Welcome to your Virtual Machine.

 

 

 

Ta s k 1 – Build Topology

 

 

Step 1             On the CiscoLab machine, at the menu at the top, go to Applications > Education > VPCS. VPCS is used to create two virtual PCs to test the emulated network that we will set up later in this lab.


 

 

The initial screen of VPCS will look like the one shown below. 


 

 

Prompt “VPCS  1 >” means that you are currently in virtual PC #1. Let us call this virtual PC “ vpcs1 ”, and the second virtual PC that we will create later “ vpcs2 ”.

 

 

 

Step 2          Let us set up the network configuration of vpcs1. We will place vpcs1 in network 192.168.0.0 (denoted as cloud 1 in the lab setup diagram). In the VPCS window, type in the following command: (Note:  Do not type in “VPCS 1 >”.  Just type in the command.)

VPCS 1 > ip 192.168.0.5 192.168.0.1 24

In the above command, the first argument is the IP address to be assigned to vpcs1, the second argument is the IP address of the default gateway which vpcs1 is connected to, and the last argument is CIDR (Classless Inter-Domain Routing) notation of the network mask (i.e., 255.255.255.0 in this case) denoting the network address of vpcs1 (i.e., 192.168.0.0).

 

Default Gateway is the IP address used as an entry and exit point to a network. It is also the address that packets are sent to when the destination IP address does not match any addresses in the Routing Table. In this lab, the default gateway addresses are the ports that serve as access points to each of the subnets.

 

Step 3          Let us create vpcs2 by typing in the following command in the VPCS window. After pressing the enter key, the prompt will change to “VPCS 2 >”

VPCS 1 > 2
VPCS 2 >

 

Step 4          We will place vpcs2 in a different network, network 192.168.1.0 denoted as cloud 1 in the lab setup diagram. Type in the following command to assign IP address 192.168.1.12 to vpcs2.

VPCS 2 >ip 192.168.1.5 192.168.1.1 24

The above command also sets the IP address 192.168.1.1 as the default gateway of vpcs2.

 

Now, we have finished setting up the virtual PCs to communicate through a router. Let us set up an experimental network where vpcs1, vpcs2, and the router are placed.

 

 

Step 5          To setup the experimental network as shown in the lab setup diagram, go to and click on Applications > Education > gns3 Graphical Network Simulator.


 

 

 

 

 

 

 

 

 

Step 6          Type in a new project name (say “Ciscolab”) in the New Project window, check all the checkboxes, and click Okay. (You can use the default destination or create a file on your desktop.)


 

 

Step 7         
Drag and drop 2 “Router c3600s” and 2 “Clouds” from the left pane (i.e., Nodes Types) to the middle pane (a blank area) as shown below:

 

 

 

Step 8         

To configure C1, right click on C1, and select “Configure”

 

 

 

Step 9          In the configuration window, select C1 in the left pane, and select the NIO UDP tab. Type in “30000”, “127.0.0.1”, and “20000” for Local port, Remote host, and Remote port respectively. Click Add. On success, you will see “nio_udp:30000:127.0.0.1:20000” on the NIOs pane. Click Okay.

 

 

 

Step 10      For C2, repeat the same procedure to configure it. But, this time, use “30001”, “127.0.0.1”, and “20001” for Local port, Remote host, and Remote port respectively. Click Add. On success, you will see “nio_udp:30001:127.0.0.1:20001” on the NIOs pane. Click Okay.

 

Step 11      Let us connect the R1 and R2 to C1 and C2 respectively. Click icon in the toolbar, and select FastEthernet. The icon will turn to , which means you are in the “add link” mode.

Let us add a link between R1 and C1. Click R1, click C1, and a menu pops up. Select “nio_udp:30000:127.0.0.1:20000” in the popup menu. Repeat the same steps for R2 and C2, and select “nio_udp:30001:127.0.0.1:20001”.


Click to finish “add link” mode.

 

Also, you can toggle showing interface names by clicking the icon in the toolbar.

Step 12      Let us connect R1 and R2 through a serial communication line, as shown in the figure below. Click icon and select “serial.” Draw a serial line between R1 and R2 by clicking R1 and then clicking R2.

Click   icon to turn the line drawing mode off.

 

Please note that the interface numbering (i.e., f n /0, s n /0) depends on the order in which you add the lines. For example, if you add the link connecting R1 and C1 first, you will get f 0 /0 and s 1 /0. If you add the serial link between R1 and R2 first, then you will get f 1 /0 and s 0 /0.

 

Step 13      R1 and R2 are initially turned off. Turn R1 on by right-clicking R1 and selecting start. Do the same thing to R2.



 

 

Step 14      Right click on one of the routers and select “Idle PC”. If a window opens saying it already has an idle pc value and asking if you would like another, hit yes. Otherwise, in the idle PC window, select the drop menu and select an idle pc number with an asterisk next to it. Hit OK.

 

Step 15      Now, you can configure R1 and R2 through Cisco IOS. To enter IOS of R1, right click R1, and select Console. On success, a window named “R1” pops up.


 

 

 

 

 

Step 16      In the R1 window, press enter to get to the “R1#” prompt.

 

 

Once you get the “R1#” prompt, type the following commands to configure R1. Tip: User the up arrow key to recall previously entered commands.

 

 

Entering configuration mode and configuring individual line:

 

R1#enable

R1#configure terminal

R1(config)#line con 0

R1(config-line)#logging syn

R1(config-line)#exit

 

 

 

 

 

 

 

 

 

Configuring interfaces connected to C1 and R1:

R1(config)#interface f0/0

R1(config-if)#ip address 192.168.0.1 255.255.255.0

R1(config-if)#no shut

R1(config-if)#exit

R1(config)#interface s1/0

R1(config-if)#ip address 10.0.0.1 255.255.255.0

R1(config-if)#no shut

R1(config-if)#exit

 

 

 

 

 

 

 

 

 

 

 

 

Again, the interface numbering (i.e., fn/0, sn/0) depends on the order in which you add the lines. If your interface numbers are different from those seen in the previous figure, replace the interface numbers in the above command with appropriate numbers seen in your design. Similarly in Step 18, you may need to change the numbers.

 

Configuring Routing Information Protocol (RIP):

RIP is the dynamic routing protocol used in ARPANET, the original Internet. RIP calculates how long  route packets take by comparing the number of hops the packet requires to reach its destination. RIP maintains a routing table on each router which it keeps accurate by sending routing update messages regularly and whenever the network topology changes.

 

R1(config)#router rip

R1(config-router)#version 2

R1(config-router)#network 192.168.0.0

R1(config-router)#network 10.0.0.0

R1(config-router)#no auto-summary

R1(config-router)#end

R1#

 

 

 

 

 

 

 

 

 

 

Step 17     
Let us configure R2. Right click R2 and open the Console.

 

Step 18      Once you get the “R2#” prompt, type the following commands to configure R2.

R2#enable

R2#configure terminal

R2(config)#line con 0

R2(config-line)#logging syn

R2(config-line)#exit

R2(config)#interface f0/0

R2(config-if)#ip address 192.168.1.1 255.255.255.0

R2(config-if)#no shut

R2(config-if)#exit

R2(config)#interface s1/0

R2(config-if)#ip address 10.0.0.2 255.255.255.0

R2(config-if)#no shut

R2(config-if)#exit

R2(config)#router rip

R2(config-router)#version 2

R2(config-router)#network 192.168.1.0

R2(config-router)#network 10.0.0.0

R2(config-router)#no auto-summary

R2(config-router)#end

R2#

 

 

Step 19      If you have any problems, try the “show” command to verify your settings. Please note you can use “show” at the “R1#/R2#” prompt – not in the configuration terminal mode which shows the “R1(config…)# prompt.

show <? or keywords>

e.g., show interface s1/0

              You can also find detailed descriptions of each command.

             

?

              Typing the ‘?’ key at the prompt will give you a list of all commands that you can use in current state.

 

<command> ?

              Typing a command followed by the ‘?’ character will give you details on the parameters of the command.

 

Task 2 – Test the Network

 

              Step 1               Let us test the network that we have just set up. Maximize the VPCS (Terminal) window. 


Step 2               Type “1” to switch to vpcs1.

 

Trace route to vpcs2 (192.168.1.5) using the following command. The trace command sends a probe packet to specified destination IP address, and discovers intermediate nodes that the packet traverses until it gets to the destination. If you have successfully configured everything, you will see the hops the packet made from vpcs1, through the router, to vpcs2.    

VPCS 2 >1

VPCS 1 >trace 192.168.1.5 –P 6

......... // trace route result appears here

Also, try the following commands to trace route from vpcs2 to vpcs1.

VPCS 1 >2

VPCS 2 >trace 192.168.0.5 –P 6

......... // trace route result appears here

The following commands may be useful in verifying virtual PC configuration. Command “show” shows the configuration of all virtual PCs.

show

Command “ping” can be used to check if a virtual PC is up and connected to network. Using the “Lab Setup Diagram” on page 1, ping each router and each cloud to be sure everything is connected.

ping <ip address>

 

Task 3– Observe the Network Traffic with WireShark

Step 1               Let us sniff the packets being transferred between R1 and R2. Right click on the serial link between R1 and R2, select “Capture.” When the Capture window shows up, select “R1 s1/0 (encapsulation: HDLC),” click OK. Now, GNS3 will start capturing traffic between R2 and R1, storing the traffic in a file named R1_to_R2.cap.

              Note: If you see the following message, go to Edit Preferences, choose the “Capture” tab, and change the “Working directory for capture files” to “/home/administrator/Desktop” (see below).

Step 2               To generate test packets to be captured, we use ping . Go to the VPCS window. Select either one of vpcs1 and vpcs2, ping another. For example, you can ping vpcs2 from vpcs1 using the following commands:

VPCS 2 >1

VPCS 1 >ping 192.168.1.5

...... (ping results)

 

Note : ping sends a fixed number of ICMP Echo requests to the destination specified by a user. On receiving an ICMP Echo request, a computer (or network device) typically replies to the sender with an ICMP Echo reply . On receiving the ICMP Echo reply, ping (running on the sender) recognizes whether the destination is reachable or not.

              Step 3               Let us see what has been captured. Click the serial link again, select “Start Wireshark”

Step 4               On success, you will see the ICMP Echo requests going from vpcs2 (192.168.1.5) to vpcs1 (192.168.0.5) and the ICMP Echo replies from vpcs1 to vpcs2.

 

Step 5               For another exercise, let us capture the packets trace sends and receives. Go to the VPCS window again; try trace vpcs1 from vpcs2 (or vice versa).

VPCS 2 >trace 192.168.0.5 –P 6

...... (trace results)

              Step 6               Go to the Wireshark window (if you have closed it, just reopen it as you did in step 4), press

Ctrl+R (i.e., View > Reload menu item or icon) to refresh the results. Go to the bottom of the list of packets to see the most recent ones.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Multi Cisco Router Configuration Report

 

Note: This is an individual lab assignment. Each student needs work on and submit his/her report independently.

 

Clearly state your results of this project. You are expected to hand in a report in the following format:

          A cover page (including Lab title) with your name and Penn State email address.

          Number pages. Font size 12, single column.

          Save the Microsoft Word or PDF document with your name in the title. Upload the document into the appropriate Canvas dropbox.

 

The report should have the following sections. Each section should cover all the topics described below. Place screenshots as indicated.  Reference the screen capture in the text you write.

 

Section I (25 pts): Task 1 - Step 12

Your answer should have the following part:

1.                   Include a screenshot of your connected experimental network. Describe what components your design include, what IP address(es) each component has, what their functions are, and where each virtual PC is.

 

Section II (45 pts): Task 2 – Step 2

Your answer should have the following parts:

1.                   Include a screenshot of your traceroute for VPCS 1.

2.                   Include a screenshot of your traceroute for VPCS 2.

3.                   Include a screenshot - ping both IP addresses to show you are connected.

 

        All three items can be captured on one screenshot.

 

Section III (30 pts): Task 3 – Step 4 and Step 6

Your answer should have the following parts:

1.                   Include screenshots of your Wireshark results for Step 4 and Step 6.

2.                   Identify the pair of ICMP request and reply in Wireshark that correspond the second ping request in the ping task in Step 2. Based on the time stamp of these two records, estimate the time for the ping request to take a round trip from the source to the destination. Compare the number with the result you got in Step 2, Task 2. Explain where the difference, if there is any, may come from.