Access Keys:
Skip to content (Access Key - 0)

Problems Updating Thunderbird or Logitech Products

Added by LAURA NICOLE MASSARO KAUFFMAN , last edited by LAURA NICOLE MASSARO KAUFFMAN on Oct 16, 2009 12:57


Problems Updating Mozilla Thunderbird or Logitech Products

If you have Logitech camera or headset installed as well as Mozilla Thunderbird, you may run into some difficulty updating either product.  Some Logitech products use the mozmapi32.dll and lock this file while running.

#top

Updating Mozilla Thunderbird (or Fixing a Bad Thunderbird Update)

Some Logitech products lock mozmapi32.dll, a file required by Thunderbird.  If these products are running while Thunderbird is updating, you could get an error regarding this file the next time you try to launch Thunderbird.

To update Thunderbird correctly or to fix a bad update, do the following:

  1. Find your Logitech products (Logitech QuickCam, Logitech Headset, etc.) in the System Tray (bottom right-hand corner of your Desktop, next to the time).
  2. For each Logitech product:
    1. Right-click.
    2. Choose Exit.
  3. Open Thunderbird.
  4. Go to Help?Check for Updates.  The Software Update dialog will appear.
  5. Click Finish.

#top

Updating Logitech Products (or Fixing a Bad Logitech Update)

Some Logitech products use mozmapi32.dll, a file required by Thunderbird.  If Thunderbird is running while a Logitech product updates, you could get an error regarding this file the next time you try to launch the product.

To update a Logitech product correctly or to fix a bad update, do the following:

  1. Close Thunderbird.
  2. Find your Logitech products (Logitech QuickCam, Logitech Headset, etc.) in the System Tray (bottom right-hand corner of your Desktop, next to the time).
  3. For each Logitech product:
    1. Right-click.
    2. Choose Check for Updates.
    3. Select updates & click Download.
    4. Click Install.

#top